Hübsche Fehlertexte mit #SVERWEIS – nicht ohne #WENN und #ISTNV


Sie kennen den #NV!Fehler, oder? Er tritt auf, wenn sich beim Anwenden der Funktion SVERWEIS herausstellt, dass der Suchschlüssel nicht gefunden ist. Was, er gefällt Ihnen nicht? Er entstellt Ihre Listen? Na, dann geben Sie im Falle des Nichtfindens eben etwas Schöneres aus. Ich zeige Ihnen, wie:

=WENN(ISTNV(SVERWEIS(A11;$B$2:$F$7;5;FALSCH));„nicht gefunden, oje!“;SVERWEIS(A11;$B$2:$F$7;5;FALSCH))

XTipp SVERWEIS Fehlerhandling1

SVERWEIS(A11;$B$2:$F$7;5;FALSCH) ist der SVERWEIS, der für den Verweis auf die zweite Liste benutzt wird. Hier wird der Inhalt von A11 im Bereich B2:F7 gesucht, der Inhalt der 5. Spalte wird zurück gegeben, falls er gefunden wird, andernfalls gibt’s den #NV!Fehler (dafür sorgt FALSCH).

Dieser SVERWEIS(A11;$B$2:$F$7;5;FALSCH) wird nun in der Formel zwei Mal verwendet:

ISTNV(SVERWEIS(A11;$B$2:$F$7;5;FALSCH)) liefert WAHR, wenn bei diesem SVERWEIS der #NV-Fehler heraus kommt. Diese Funktion verwende ich als Bedingung im WENN – und wenn eben WAHR herauskommt, wird der Alternativtext
nicht gefunden, oje! ausgegeben, sonst das Ergebnis des SVERWEIS – da kommt die Funktion noch einmal ins Spiel.

Fertig 🙂

XTipp SVERWEIS Fehlerhandling2

Falls Sie Lust auf eine Extraaufgabe haben, versuchen Sie doch, diese Ergebnisse mit bedingter Formatierung einzufärben – dafür gibt’s ein paar Varianten.

Über katharinakanns

Microsoft Office Master Specialist mit viel Verständnis für IHR Geschäft - ich analysiere IHRE Situation, optimiere IHRE Prozesse, automatisiere IHRE Routineaufgaben, finde IHRE Lösung, unterrichte IHRE MitarbeiterInnen, mache Vorlagen mit IHRER CI, spare IHRE Zeit und IHR Geld. Ich freue mich darauf, SIE kennenlernen zu dürfen :-)
Dieser Beitrag wurde unter Excel abgelegt und mit , , , , , , , , verschlagwortet. Setze ein Lesezeichen auf den Permalink.

Kommentar verfassen

Trage deine Daten unten ein oder klicke ein Icon um dich einzuloggen:

WordPress.com-Logo

Du kommentierst mit Deinem WordPress.com-Konto. Abmelden / Ändern )

Twitter-Bild

Du kommentierst mit Deinem Twitter-Konto. Abmelden / Ändern )

Facebook-Foto

Du kommentierst mit Deinem Facebook-Konto. Abmelden / Ändern )

Google+ Foto

Du kommentierst mit Deinem Google+-Konto. Abmelden / Ändern )

Verbinde mit %s