nur in jeder zweiten #Zeile


Sie wollen eine Formel haben, die nur in jeder zweiten Zeile ein Ergebnis liefert? Zum Beispiel, weil Sie aus einem Fremdsystem Daten zweizeilig angeliefert bekommen (ist zwar blöd, soll’s aber geben). Dann müssen Sie mit dem Divisionsrest arbeiten:

XTipp jede zweite Zeile

In meinem Beispiel möchte ich in der Spalte D in jeder zweiten Zeile den Inhalt der Spalte B durch den der Spalte C teilen. Aber eben nur in jeder zweiten – in den anderen Zeilen stehen Namen, mit denen kann und will ich nicht rechnen. Daher erstelle ich folgende Formel:

=WENN(REST(ZEILE();2)=0;RUNDEN(B1/C1;2);““)

Ist also der Divisionsrest beim Teilen der aktuellen Zeile (ZEILE() liefert genau das) durch 2 (das liefert REST(ZEILE();2) gleich 0, dann wird gerechnet, sonst nicht.

Über katharinakanns

Microsoft Office Master Specialist mit viel Verständnis für IHR Geschäft - ich analysiere IHRE Situation, optimiere IHRE Prozesse, automatisiere IHRE Routineaufgaben, finde IHRE Lösung, unterrichte IHRE MitarbeiterInnen, mache Vorlagen mit IHRER CI, spare IHRE Zeit und IHR Geld. Ich freue mich darauf, SIE kennenlernen zu dürfen :-)
Dieser Beitrag wurde unter Excel abgelegt und mit , , , , , verschlagwortet. Setze ein Lesezeichen auf den Permalink.

Kommentar verfassen

Trage deine Daten unten ein oder klicke ein Icon um dich einzuloggen:

WordPress.com-Logo

Du kommentierst mit Deinem WordPress.com-Konto. Abmelden / Ändern )

Twitter-Bild

Du kommentierst mit Deinem Twitter-Konto. Abmelden / Ändern )

Facebook-Foto

Du kommentierst mit Deinem Facebook-Konto. Abmelden / Ändern )

Google+ Foto

Du kommentierst mit Deinem Google+-Konto. Abmelden / Ändern )

Verbinde mit %s