#Wörter #zählen #Excel


Sie wollen wissen, wie viele #Wörter in Ihrer #Zelle in #Excel stehen?

Ich hab eine Formel für Sie:

=WENN(ISTLEER(A1);0;LÄNGE(A1)-LÄNGE(ERSETZEN(A1;“ „;““))+1)

Was die macht? Sie zählt die Leerzeichen, und zählt dann noch 1 dazu. Aber nur, falls die Zelle nicht leer ist.

Und wie?

Die Differenz der Länge des Inhalts und der Länge des Inhalts, wenn man alle Leerzeichen durch „nichts“ (eine leere Zeichenkette „“) ersetzt, sagt, wie viele Leerzeichen da drin waren. Katharina Schwarzer enthält ein Leerzeichen, und es sind zwei Wörter, also muss zum Ergebnis noch 1 dazu gerechnet werden. Wenn allerdings gar nichts in der Zelle steht, dann sind das 0 Wörtern, dafür sorgen das WENN und das ISTLEER.

Über katharinakanns

Microsoft Office Master Specialist mit viel Verständnis für IHR Geschäft - ich analysiere IHRE Situation, optimiere IHRE Prozesse, automatisiere IHRE Routineaufgaben, finde IHRE Lösung, unterrichte IHRE MitarbeiterInnen, mache Vorlagen mit IHRER CI, spare IHRE Zeit und IHR Geld. Ich freue mich darauf, SIE kennenlernen zu dürfen :-)
Dieser Beitrag wurde unter Excel, Uncategorized abgelegt und mit , , , , , , , verschlagwortet. Setze ein Lesezeichen auf den Permalink.

Kommentar verfassen

Trage deine Daten unten ein oder klicke ein Icon um dich einzuloggen:

WordPress.com-Logo

Du kommentierst mit Deinem WordPress.com-Konto. Abmelden /  Ändern )

Google+ Foto

Du kommentierst mit Deinem Google+-Konto. Abmelden /  Ändern )

Twitter-Bild

Du kommentierst mit Deinem Twitter-Konto. Abmelden /  Ändern )

Facebook-Foto

Du kommentierst mit Deinem Facebook-Konto. Abmelden /  Ändern )

Verbinde mit %s