#ZEILE und #SPALTE und #wozudasalles – oha, #SVERWEIS!


Ein Beispiel für die Verwendung von ZEILE() hab ich Ihnen schon am Montag geliefert. Ein weiteres: =WENN(B1=ZEILE();„entspricht der Zeilennummer“;„ist ganz anders“) liefert Ihnen die Information, ob das, was in B1 (B2, B3, …) steht, der aktuellen Zeilennummer der Funktion entspricht.

XTipp ZEILE()

Sagen wir’s besser ganz allgemein: Wann immer Sie in einer Formel eine Zahl benötigen, die von Zeile zu Zeile um 1 größer sein soll, ist ZELLE() Ihr Freund.

Und SPALTE()?

Haben Sie sich nicht schon ab und zu geärgert, dass Sie für jede Spalte den SVERWEIS neu schreiben mussten, wenn Sie einen Bereich aus mehreren Spalten füllen mussten? Weil ja das dritte Argument, die Spaltennummer, beim AutoAusfüllen nicht „mitrutscht“? Aha. Klingelt’s schon? Schauen Sie sich das Beispiel an:

XTipp SPALTE

Ist doch schön:
=SVERWEIS($A11;$B$2:$I$7;SPALTE()-1;FALSCH) wurde genau so in die Zelle F11 geschrieben, damit

  • der Inhalt der Spalte A in der aktuellen Zeile gesucht wird ($A11, und das Dollarzeichen fixiert die Spalte A)
  • im Bereich B2:I7 gesucht wird (und zwar immer – daher die vielen Dollarzeichen)
  • der Inhalt der Spalte aus dem Bereich B2:I7 zurückgegeben wird, deren Nummer
    um 1 kleiner ist als die Nummer der aktuellen Spalte (für den Besitzer brauchen wir beispielsweise den Inhalt der fünften Spalte aus B2:I7, die Formel steht in der sechsten Spalte des Blattes, daher müssen wir eins abziehen)
  • nur exakte Treffer ermittelt werden (das macht das FALSCH)

Diese Formel lässt sich nun nach rechts ausfüllen und nach unten ausfüllen, ohne dass Sie noch etwas daran herumbasteln müssen.

Sagen Sie nur, das mach Ihnen keine Freude!

Über katharinakanns

Microsoft Office Master Specialist mit viel Verständnis für IHR Geschäft - ich analysiere IHRE Situation, optimiere IHRE Prozesse, automatisiere IHRE Routineaufgaben, finde IHRE Lösung, unterrichte IHRE MitarbeiterInnen, mache Vorlagen mit IHRER CI, spare IHRE Zeit und IHR Geld. Ich freue mich darauf, SIE kennenlernen zu dürfen :-)
Dieser Beitrag wurde unter Excel abgelegt und mit , , , , , , , , , verschlagwortet. Setze ein Lesezeichen auf den Permalink.

Kommentar verfassen

Trage deine Daten unten ein oder klicke ein Icon um dich einzuloggen:

WordPress.com-Logo

Du kommentierst mit Deinem WordPress.com-Konto. Abmelden / Ändern )

Twitter-Bild

Du kommentierst mit Deinem Twitter-Konto. Abmelden / Ändern )

Facebook-Foto

Du kommentierst mit Deinem Facebook-Konto. Abmelden / Ändern )

Google+ Foto

Du kommentierst mit Deinem Google+-Konto. Abmelden / Ändern )

Verbinde mit %s