Daten zählen, die mehreren Kriterien entsprechen


Sie erinnern sich an ZÄHLENWENN? Die Funktion, mit der Sie Einträge in einer Liste zählen können, die bestimmten Kriterien genügen. Zum Beispiel können Sie aus einer Geschenkeliste ermitteln, wie viele Geschenke Anton bekommt. Dazu gab es (siehe Link) schon eine ganze Serie an Tipps.

Ich meg heute ZÄHLENWENNS vorstellen; ein naher Verwandter. Mit dieser Funktion können Sie eine Liste auf mehrere Kriterien hin überprüfen, und nur die Einträge zählen, die beiden (allen drei, allen vier,  …) Kriterien entsprechen.

XTipp ZählenwennsIn diesem Beispiel interessiert mich nicht, wer wie viele Geschenke bekommt, sondern wer wie viel Spielzeug bekommt. =ZÄHLENWENNS($A$1:$A$9;A12;$B$1:$B$9;B12) macht nun folgendes:

Im Bereich $A$1:$A$9 wird geschaut, ob drin dasselbe steht wie in A12, im aktuellen Fall also Anton. Jedes Mal, wenn ein Anton gefunden wird, wird in der dazu passenden Zelle in $B$1:$B$9 geschaut, ob drin dasselbe steht wie in B12, wo ich Spielzeug hineingeschrieben habe. Ist das ebenfalls der Fall, so wird der Datensatz gezählt.

Ein Paar aus Bereich und Kriterium gehört also immer zusammen, und mit zwei (oder mehr) solcher Paare lassen sich zwei (oder mehr) solche Kriterien überprüfen.

Wichtig: Die Bereiche, in denen gesucht wird, müssen nicht nebeneinander liegen. Aber: sie müssen gleich groß sein. Sonst gibt’s eine unschöne Fehlermeldung.

Über katharinakanns

Microsoft Office Master Specialist mit viel Verständnis für IHR Geschäft - ich analysiere IHRE Situation, optimiere IHRE Prozesse, automatisiere IHRE Routineaufgaben, finde IHRE Lösung, unterrichte IHRE MitarbeiterInnen, mache Vorlagen mit IHRER CI, spare IHRE Zeit und IHR Geld. Ich freue mich darauf, SIE kennenlernen zu dürfen :-)
Dieser Beitrag wurde unter Excel abgelegt und mit , , , , , , verschlagwortet. Setze ein Lesezeichen auf den Permalink.

5 Antworten zu Daten zählen, die mehreren Kriterien entsprechen

  1. Gerhard Pundt schreibt:

    Hallo Katharina,
    ja, die WENNS-Funktionen. Mir macht es immer wieder Spaß, damit zu arbeiten. Einen schönen Beitrag hast Du hier geschrieben.
    Viele Grüße
    Gerhard
    PS: vielleicht mags Du auch hier mal schauen?
    https://clevercalcul.wordpress.com

    Gefällt mir

  2. Pingback: #Platzhalter-Kriterien für die ZÄHLENWENN- und SUMMEWENN-Familie | Soprani Software

  3. Pingback: #MITTELWERTWENNS #schöneneueFunktion | Soprani Software

Kommentar verfassen

Trage deine Daten unten ein oder klicke ein Icon um dich einzuloggen:

WordPress.com-Logo

Du kommentierst mit Deinem WordPress.com-Konto. Abmelden / Ändern )

Twitter-Bild

Du kommentierst mit Deinem Twitter-Konto. Abmelden / Ändern )

Facebook-Foto

Du kommentierst mit Deinem Facebook-Konto. Abmelden / Ändern )

Google+ Foto

Du kommentierst mit Deinem Google+-Konto. Abmelden / Ändern )

Verbinde mit %s