#Summe berechnen – aber nur, wenn …


Ein Weg, um die #Summe von #ausgewählten #Werten zu berechnen, wenn #SUMMEWENN nicht ausreicht (Prüfung auf leere Zellen, numerische Inhalte, Teilstrings, …): mit Hilfe von #SUMMENPRODUKT.

Was wir wissen müssen:

  • SUMMENPRODUKT kann ich verwenden, um mehrere Matrizen Zeile für Zeile zu verarbeiten, und die einzelnen Ergebnisse zu summieren.
  • ISTZAHL, ISTFEHLER, aber auch jeglicher Vergleich liefern als Ergebnis WAHR oder FALSCH – und WAHR repräsentiert in Wirklichkeit 1, FALSCH ist dasselbe wie 0.

Damit kann es losgehen. Was wir machen ist Folgendes:

Wir multiplizieren Wahrheitswerte mit den Zahlen. Ist ein Wahrheitswert 0, dann ist das Ergebnis für diese Zeile der Matrix 0, sie wirkt sich also auf die Summe nicht aus. Sind alle Wahrheitswerte 1, dann fließt die Zahl in die Summe ein.

Drei Beispiele zum besseren Verständnis:

XTipp Summenprodukt Wahrheit

=SUMMENPRODUKT(ISTLEER(B2:B11)*C2:C11)
B2 ist nicht leer, daher ergibt ISTLEER(B2) 00*300=0
B3 ist nicht leer, daher ergibt ISTLEER(B3) 00*100=0
B4 ist leer, daher ergibt ISTLEER(B4) 1, 1*200=200

B8 ist leer, daher ergibt ISTLEER(B8) 1, 1*600=600

200+600=800 Das ist das gesuchte Ergebnis.

=SUMMENPRODUKT((A2:A11=“Haushalt)*ISTLEER(B2:B11)*C2:C11)
siehe oben, nur ergänzt um die Prüfung, ob in A2, A3, … „Haushalt“ steht. Nur in einer einzigen Zeile – Zeile 3 – ergibt sich das Bild A3=“Haushalt“ ist WAHR, ISTLEER(B3) ist WAHR, daher 1*1*200=200. In allen anderen Zeilen ist entweder der erste oder der zweite Faktor 0, sie fließen daher in das Ergebnis nicht ein.

=SUMMENPRODUKT((LINKS(B2:B11;1)=“E)*C2:C11)
Hier ist die Prüfung, ob der erste Buchstabe des Wertes in Spalte B ein E ist. LINKS(B2;1) ist zum Beispiel WAHR, also 1, daher sind die 300 aus C2 im Ergebnis dabei; LINKS(B3;1) ist FALSCH, also 0, und die 200 aus C3 spielen nicht mit.

Die eigentliche Produktfunktion von SUMMENPRODUKT ist hier übrigens nicht zur Anwendung gekommen – ich hab die erzeugte Teilsummenmatrix mit nichts mehr multipliziert; die ganze Funktion hat nur ein einziges Argument. Dies nur der Vollständigkeit halber, damit niemand motzt. Lassen Sie sich von dieser Detailklauberei nicht verwirren 🙂

„Das braucht kein Mensch,“ hör‘ ich Sie murmeln – aber, glauben Sie mir, ich bin schon einigen Situationen begegnet, die sich nicht anders lösen ließen.

 

 

Über katharinakanns

Microsoft Office Master Specialist mit viel Verständnis für IHR Geschäft - ich analysiere IHRE Situation, optimiere IHRE Prozesse, automatisiere IHRE Routineaufgaben, finde IHRE Lösung, unterrichte IHRE MitarbeiterInnen, mache Vorlagen mit IHRER CI, spare IHRE Zeit und IHR Geld. Ich freue mich darauf, SIE kennenlernen zu dürfen :-)
Dieser Beitrag wurde unter Excel abgelegt und mit , , , , , , , , verschlagwortet. Setze ein Lesezeichen auf den Permalink.

Kommentar verfassen

Trage deine Daten unten ein oder klicke ein Icon um dich einzuloggen:

WordPress.com-Logo

Du kommentierst mit Deinem WordPress.com-Konto. Abmelden /  Ändern )

Google+ Foto

Du kommentierst mit Deinem Google+-Konto. Abmelden /  Ändern )

Twitter-Bild

Du kommentierst mit Deinem Twitter-Konto. Abmelden /  Ändern )

Facebook-Foto

Du kommentierst mit Deinem Facebook-Konto. Abmelden /  Ändern )

Verbinde mit %s