Excel #Datenauswahl aus #Liste mit #Großkleinschreibung


Was Kniffliges: Sie wollen mit Excel die Dateneingabe auf Daten aus einer vorgegebenen Liste einschränken – dann geht das so. Sie erinnern sich? Es entsteht ein DropDown mit Ihren Vorgabewerten.

(Manchmal) ärgerlich ist nur: Egal, welche Vorgabe bezüglich Groß- und Kleinschreibung Sie in Ihrer Liste machen, die Eingabe wird nicht dahingehend geprüft, wenn der Benutzer das Dropdown nicht nützt, sondern einfach eintippt. Steht in Ihrer Liste zum Beispiel Katze, so darf der Benutzer auch katze oder kATZE oder kAtZe eingeben … Sie verstehen schon. Wenn Sie das aber nicht wollen? Was dann?

Dann: geben Sie ins Feld Quelle im Datenüberprüfung-Dialog Folgendes ein:

=WENN(ODER(IDENTISCH(A1;$F$1:$F$3))+(A1=““);$F$1:$F$3;$IV$1)

wobei

  • A1 die erste Zelle in dem Datenbereich ist, für den die Gültigkeitsprüfung gilt
  • $F$1:$F$3 der Bereich ist, in dem die zulässigen Werte stehen; das darf natürlich auch ein benannter Bereich sein
  • $IV$1 irgendeine Zelle ist, die leer sein muss

???

Also: IDENTISCH(A1;$F$1:$F$3) liefert eine Reihe von Wahrheitswerten, die alle FALSCH sind, es sei denn, A1 entspricht exakt einem der Werte in F1:F3, dann ist ein Wert der Reihe WAHR. Mit +(A1=““) wird auch noch nachgefragt, ob in A1 vielleicht gar nichts drinsteht – auch dann wollen wir die Wahl haben.

ODER liefert WAHR, wenn auch nur ein einziger Wert in dieser Reihe WAHR ist.

Und in diesem Fall werden die Werte für das DropDown aus F1:F3 geholt. Andernfalls kommt die leere Zelle IV1 zum Zug.

Klar? Viel Vergnügen!

XTipp DropDown Case sensitive

 

Über katharinakanns

Microsoft Office Master Specialist mit viel Verständnis für IHR Geschäft - ich analysiere IHRE Situation, optimiere IHRE Prozesse, automatisiere IHRE Routineaufgaben, finde IHRE Lösung, unterrichte IHRE MitarbeiterInnen, mache Vorlagen mit IHRER CI, spare IHRE Zeit und IHR Geld. Ich freue mich darauf, SIE kennenlernen zu dürfen :-)
Dieser Beitrag wurde unter Excel, Uncategorized abgelegt und mit , , , , , , , verschlagwortet. Setze ein Lesezeichen auf den Permalink.

Kommentar verfassen

Trage deine Daten unten ein oder klicke ein Icon um dich einzuloggen:

WordPress.com-Logo

Du kommentierst mit Deinem WordPress.com-Konto. Abmelden / Ändern )

Twitter-Bild

Du kommentierst mit Deinem Twitter-Konto. Abmelden / Ändern )

Facebook-Foto

Du kommentierst mit Deinem Facebook-Konto. Abmelden / Ändern )

Google+ Foto

Du kommentierst mit Deinem Google+-Konto. Abmelden / Ändern )

Verbinde mit %s