#signifikante #Stellen


Sie wollen ein Ergebnis auf eine bestimmte Anzahl Stellen genau ausgeben – und zwar eine, die nicht absolut ist, sondern relativ zur Länge der Zahl. Sagen wir, Sie bestimmen Flächen – dann interessieren Sie beim Ergebnis vielleicht immer fünf Stellen Genauigkeit; aber je nach Ergebnis andere fünf Stellen (z.B. 1234,5 oder 123450000 oder 1234500 oder 0,000012345).

Das können Sie mit einer Formel erreichen:
=RUNDEN(A1;(-GANZZAHL(LOG(A1))+(B1-1))) Wobei in A1 die zu rundende Zahl steht, in B1 die Anzahl der signifikanten Stellen, für die Sie sich interessieren.

Das funktioniert so (am Beispiel 42499 und 2 signifikanten Stellen – wir wollen also auf -3 Stellen runden):

Mit LOG(A1) wird die Anzahl der Zehnerpotenzen bestimmt, die sich in der Zahl ausgehen – bei unserem Beispiel sind es 4,62…. Und wie machen wir daraus die gesuchten -3? Zunächst nehmen wir nur die Stellen vor dem Komma, das macht GANZZAHL, und das Ergebnis mal -1. Macht -4. Dann zählen wir die 2 dazu, weil wir ja 2 signifikante Stellen haben wollen, und ziehen wieder 1 ab, weil das sonst zu weit geht. Macht -3. Geschafft.

XTipp signifikante Stellen

Über katharinakanns

Microsoft Office Master Specialist mit viel Verständnis für IHR Geschäft - ich analysiere IHRE Situation, optimiere IHRE Prozesse, automatisiere IHRE Routineaufgaben, finde IHRE Lösung, unterrichte IHRE MitarbeiterInnen, mache Vorlagen mit IHRER CI, spare IHRE Zeit und IHR Geld. Ich freue mich darauf, SIE kennenlernen zu dürfen :-)
Dieser Beitrag wurde unter Excel abgelegt und mit , , , , , , verschlagwortet. Setze ein Lesezeichen auf den Permalink.

Kommentar verfassen

Trage deine Daten unten ein oder klicke ein Icon um dich einzuloggen:

WordPress.com-Logo

Du kommentierst mit Deinem WordPress.com-Konto. Abmelden /  Ändern )

Google+ Foto

Du kommentierst mit Deinem Google+-Konto. Abmelden /  Ändern )

Twitter-Bild

Du kommentierst mit Deinem Twitter-Konto. Abmelden /  Ändern )

Facebook-Foto

Du kommentierst mit Deinem Facebook-Konto. Abmelden /  Ändern )

Verbinde mit %s