Anzahl der eindeutigen Einträge in Excel zählen


Kennen Sie folgende Situation: Sie haben eine lange Liste von Einträgen, manches kommt doppelt vor, manches noch öfter – und nun fragt Sie jemand, wie viele verschiedene Einträge Sie in dieser Liste haben. Ein Beispiel:

XTipp eindeutige zählen 1

Hier gibt’s einen Haufen Namen, und gefragt ist: wie viele verschiedene sind’s? Antwort: 4 – aber nicht alle Listen sind so kurz und überschaubar, dass man das doch gerne manuell zählt. Wie lässt sich das lösen?

Wir brauchen zunächst noch eine Hilfsspalte. In diese geben wir eine schöne Formel ein und verwenden dabei die Funktion ZÄHLENWENN:

XTipp eindeutige zählen 2

=ZÄHLENWENN($A$1:A1;A1)

Damit wird gezählt, wie oft der nebenstehende Begriff in der Liste bereits vorkommt. Das ist direkt nach der Eingabe der Formel noch etwas unverständlich; wenn Sie aber die Formel nach unten ziehen und mit ihr die ganze Spalte ausfüllen, dann wird’s offensichtlich:

XTipp eindeutige zählen 3

Durch das Setzen der Dollarzeichen in der Ursprungsformel wird nun immer ermittelt, wie oft der nebenstehende Begriff (hier in rot: Cäsar, aus A8) im bisherigen Bereich (hier in blau: $A$1:A8, also immer vom Anfang der Liste bis zur aktuellen Zeile) bereits vorgekommen ist.

Und wozu die Mühe? Nun … beim ersten Vorkommen eines Begriffs steht damit 1 in der Hilfsspalte, bei allen weiteren Vorkommen etwas Höheres, das uns für unser Problem nicht weiter interessiert.

Jetzt brauchen wir nur in der Zelle, in der wir unser Ergebnis haben wollen, eine weitere Formel eingeben:

XTipp eindeutige zählen 4

=ZÄHLENWENN(B1:B14;1)

zählt, wie viele 1er in unserer Hilfsspalte vorkommen – 4 Stück. Problem gelöst. Auch, wenn es nicht um 14 Zellen geht, sondern um 14000.

Über katharinakanns

Microsoft Office Master Specialist mit viel Verständnis für IHR Geschäft - ich analysiere IHRE Situation, optimiere IHRE Prozesse, automatisiere IHRE Routineaufgaben, finde IHRE Lösung, unterrichte IHRE MitarbeiterInnen, mache Vorlagen mit IHRER CI, spare IHRE Zeit und IHR Geld. Ich freue mich darauf, SIE kennenlernen zu dürfen :-)
Dieser Beitrag wurde unter Excel abgelegt und mit , , , , , , , , , verschlagwortet. Setze ein Lesezeichen auf den Permalink.

Kommentar verfassen

Trage deine Daten unten ein oder klicke ein Icon um dich einzuloggen:

WordPress.com-Logo

Du kommentierst mit Deinem WordPress.com-Konto. Abmelden / Ändern )

Twitter-Bild

Du kommentierst mit Deinem Twitter-Konto. Abmelden / Ändern )

Facebook-Foto

Du kommentierst mit Deinem Facebook-Konto. Abmelden / Ändern )

Google+ Foto

Du kommentierst mit Deinem Google+-Konto. Abmelden / Ändern )

Verbinde mit %s